EEGER
SOFTWARE
CHANGELOG
EEGer4
Software
Changelog
Release
Notes
for
EEGer4
440y
(April
2023)
EEGer4
440y
has
been
released,
allowing
us
to
make
more
rapid
improvements
to
the
software
and
laying
the
groundwork
for
larger
changes
coming
in
the
future.
Additionally,
a
strong
focus
has
been
put
towards
improving
usability
and
implementing
the
first
iterations
of
new
features
that
will
be
fully
supported
in
upcoming
versions.
New
Features
These
are
key
changes
made
in
this
version
intended
to
expand
EEGer’s
functionality,
make
the
software
easier
to
use,
or
to
implement
requested
features.
Added
button
to
Utilities
menu
that
allows
for
EEGer
Consultation
Files
(and
other
Efiles)
to
be
uploaded
from
clinical
EEGer
systems.
Initial
implementation
uses
the
EEGer
Home
Use
Cloud
Utility
as
its
base,
but
allows
for
ELP,
ELS,
and
ECE
files
to
be
uploaded
and
shared
with
other
Clinical
and
Home
Use
systems
using
the
EEGer
Cloud.
The
current
implementation
is
intended
for
testing
purposes,
and
the
functionality
will
be
expanded
In
an
upcoming
release.
Removed
irrelevant
Client
ID
information
from
EEGer
files
such
as
Consultation
Exports
to
prevent
possible
PHI
from
leaving
the
system
or
being
accessible
from
outside
of
EEGer.
Expanded
Plan
Session
&
Live
Recording
functionality
to
allow
for
reward
frequencies
within
0.001
Hz
ranges
for
supported
devices
while
using
advanced
filtering
modes.
Revised
GetKeyfiles
to
only
check
for
new
keyfiles
at
the
first
run
of
each
day,
requiring
the
user
to
manually
trigger
GetKeyfiles
using
the
Files
menu
if
subsequent
checks
are
needed.
Added
local
generation
of
kaction
files
to
streamline
troubleshooting
of
advanced
issues
by
EEGer
Support.
Revised
AutoAmp
Amplifier
Picking
Logic
to
only
check
for
a
connected
amplifier
during
the
first
run,
requiring
the
user
to
manually
trigger
AutoAmp
using
the
Tools
menu
if
subsequent
checks
are
needed.
In
situations
which
required
the
Client
ID
to
be
unselected
for
an
operation
to
work,
EEGer
now
does
this
manually
for
the
user
to
prevent
errors
and
improve
usability.
EEGer
now
checks
for
available
disk
space
before
running
(20
MB
minimum).
Adjusted
the
order
of
certain
submenu
buttons
to
be
more
consistent.
Updated
session
naming
to
use
new
format,
as
well
as
autorunning
eegnamefix
during
an
installation
of
440y
to
correct
any
old
session
files
present
on
the
system.
This
ensures
sessions
appear
in
order
on
the
Replay
Screen
and
Review
Screen.
Disabled
ability
to
create
consultation
exports
of
files
using
the
old
session
format,
including
the
demonstration
files,
to
prevent
possible
errors.
Updated
expiration
warning
messages
to
ensure
that
the
expiration
date
for
all
subscription
types
is
present
on
EEGer’s
main
screen
and
that
users
receive
warnings
about
upcoming
expirations
in
all
use
cases.
Added
error
reporting/logging
if
Upload
Tech
Data
fails
to
run.
Updated
the
Operator’s
Manual
to
reflect
changes
to
menus
and
new
usability
changes.
Forced
Consultation
Exports
to
be
always
encoded
to
ensure
possible
PHI
is
removed.
Added
helpful
support
utilities
with
the
base
installation
of
EEGer
to
assist
with
troubleshooting.
Adjusted
name
of
EEGer
utility
to
close
all
running
instances
of
EEGer.
ESCv230412-CP
1
EEGer4
Software
Changelog
Updated
internal
web
links.
Changed
default
launcher
options
to
accommodate
recent
changes.
Added
new
DLLs
for
NeuroAmp
devices
(ensures
support
of
NeuroAmp
I
devices).
Bug
Fixes
This
is
a
selection
of
errors
resolved
with
this
release,
as
well
as
improvements
made
to
existing
features
to
bring
them
in
line
with
our
original
intentions.
While
issues
are
encountered
and
resolved
during
development,
we
thank
all
users
who
take
time
to
report
problems
or
provide
suggestions.
Corrected
a
crash
that
could
occur
when
changing
the
background
due
to
systematic
color
changes
in
the
previous
release.
Added
signing
to
EEGer
&
Utilities
to
prevent
installation
errors
due
to
Windows
Security
or
some
Antivirus
Programs.
Corrected
use
cases
that
could
cause
crashing
when
selecting
the
Wiz
or
Optima
devices.
Corrected
an
error
causing
most
expiration
warnings
to
occur
with
only
5
days
notice
(instead
of
30
days).
Removed
requirement
for
S-VR
enable
to
access
EEGer
Cloud
which
could
prevent
certain
licenses
from
receiving
EFiles
from
other
systems.
Added
several
checks
to
prevent
‘click
too
fast’
errors
that
could
create
inconsistent
crashing
on
previous
versions.
Corrected
SMR
8p
default
feedback
mode.
Changed
Jumpbox
to
use
Classic
mode
by
default
due
to
possible
memory
issues
while
using
Modern
Jumpbox.
Corrected
cases
where
incorrect
impedance
measurements
could
be
observed
when
using
Wiz
devices.
Unresolved
Issues
These
are
issues
that
have
been
observed
in
the
software
or
reported
by
users,
but
are
not
resolved
by
this
software
update.
Work
will
continue
to
address
these
issues
in
upcoming
releases
of
the
software.
Users
who
are
impacted
are
encouraged
to
contact
technical
support
for
possible
workarounds,
to
provide
additional
information
from
their
systems,
and
to
be
notified
when
these
issues
are
resolved.
In
some
instances
the
Client
Info
Box
may
not
be
refreshed,
which
is
fixed
by
reselecting
the
Client
ID.
When
EEGer
detects
a
bad
directory
for
client
files,
selecting
‘No’
to
the
default
will
cause
the
software
to
close
and
continue
running
in
the
background
until
fully
closed.
This
is
avoided
by
accepting
the
default
path
(C://EEGer/CLIENTS)
for
the
duration
of
use
and
moving
files
when
the
intended
directory
is
available.
Certain
bad
directory
messages
when
using
a
network
drive
can
cause
no
error
to
be
reported.
Entering
a
valid
directory
will
resolve
the
issue.
In
certain
conditions,
the
Plan
Session
may
not
save
until
the
Client
ID
is
reselected.
This
is
suspected
to
be
a
procedural
issue,
and
has
not
been
consistently
reproduced.
If
you
are
encountering
this
issue,
please
contact
EEGer
Support
for
further
troubleshooting.
On
certain
Windows
11
configurations,
Dongle
Drivers
may
need
to
be
installed
manually
rather
than
via
the
Tech
Support
Menu
(KEYLOK
II).
Crashing
may
be
observed
when
starting
EEGer
with
a
ProSB
or
TTUSB
adapter
connected
if
AutoAmp
is
enabled.
Waiting
to
connect
the
amplifier
until
EEGer’s
second
run
and
manually
configuring
the
device
will
avoid
this
issue.
On
certain
Windows
11
configurations,
zoom
levels
above
100%
may
cause
non-critical
elements
of
EEGer’s
main
screen
to
appear
beyond
the
bottom
of
the
window.
This
does
not
impact
submenus
or
the
wave
screen
during
a
live
or
replay
session.
On
certain
Windows
11
configurations,
Print
actions
may
not
be
possible
from
within
EEGer.
Users
are
advised
to
use
built-in
Windows
Apps
such
as
Snipping
Tool
or
the
Windows
File
Explorer
to
take
or
view
screenshots
if
needed.
ESCv230412-CP
2